新建1个ArrayList<String> strList
用来存放字符串,然后进行如下操作。
提示: 查询Jdk文档中的ArrayList。
注意: 请使用System.out.println(strList)
输出列表元素。
输入格式
-
输入: n个字符串,放入
strList
。直到输入为!!end!!
时,结束输入。 -
在
strList
头部新增一个begin
,尾部新增一个end
。 -
输出列表元素
-
输入: 字符串
str
-
判断
strList
中有无包含字符串str
,如包含输出true
,否则输出false
。并且输出下标,没包含返回-1。 -
在strList中从后往前找。返回其下标,找不到返回-1。
-
移除掉第1个(下标为0)元素,并输出。然后输出列表元素。
-
输入: 字符串str
-
将第2个(下标为1)元素设置为字符串str.
-
输出列表元素
-
输入: 字符串str
-
遍历strList,将字符串中包含str的元素放入另外一个
ArrayList strList1
,然后输出strList1。 -
在strList中使用
remove
方法,移除第一个和str相等的元素。 -
输出strList列表元素。
-
使用
clear
方法,清空strList。然后输出strList的内容,size()
与isEmpty()
,3者之间用,
连接。
输入样例:
a1 b1 3b a2 b2 12b c d !!end!!
b1
second
b
输出样例:
[begin, a1, b1, 3b, a2, b2, 12b, c, d, end]
true
2
2
begin
[a1, b1, 3b, a2, b2, 12b, c, d, end]
[a1, second, 3b, a2, b2, 12b, c, d, end]
[3b, b2, 12b]
[a1, second, 3b, a2, b2, 12b, c, d, end]
[],0,true
import java.util.ArrayList;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
ArrayList<String> strList = new ArrayList<>();
String inputStr = in.next();
while(!inputStr.equals("!!end!!")) {
strList.add(inputStr);
inputStr = in.next();
}
strList.add(0,"begin");
strList.add("end");
System.out.println(strList);
String str = in.next();
System.out.println(strList.contains(str));
System.out.println(strList.indexOf(str));
System.out.println(strList.lastIndexOf(str));
System.out.println(strList.remove(0));
System.out.println(strList);
str = in.next();
strList.set(1, str);
System.out.println(strList);
str = in.next();
ArrayList<String> strList1 = new ArrayList<>();
for(String aString : strList) {
if(aString.indexOf(str)!=-1) {
strList1.add(aString);
}
}
System.out.println(strList1);
strList.remove(str);
System.out.println(strList);
strList.clear();
System.out.println(strList+","+strList.size()+","+strList.isEmpty());
}
}
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。
文章由极客之音整理,本文链接:https://www.bmabk.com/index.php/post/103102.html