定义IllegalScoreException
异常类,代表分数相加后超出合理范围的异常。该异常是checked exception
,即希望该异常一定要被捕获处理。
定义IllegalNameException
异常类,代表名字设置不合理的异常。该异常是unchecked exception
定义Student
类。
属性:
private String name;
private int score;
方法:
toString //自动生成
setter/getter //自动生成
改造setName //如果姓名首字母为数字则抛出IllegalNameException
public int addScore(int score) //如果加分后分数<0 或>100,则抛出IllegalScoreException,加分不成功。
###main方法:
- 输入
new
则新建学生对象。然后输入一行学生数据,格式为姓名 年龄
,接着调用setName,addScore。否则跳出循环。 - setName不成功则抛出异常,并打印异常信息,然后继续下一行的处理。
- addScore不成功则抛出异常,并打印异常信息,然后继续下一行的处理。如果2、3都成功,则打印学生信息(
toString
) - 如果在解析学生数据行的时候发生其他异常,则打印异常信息,然后继续下一行的处理。
- Scanner也是一种资源,希望程序中不管有没有抛出异常,都要关闭。关闭后,使用
System.out.println("scanner closed")
打印关闭信息
注意:使用System.out.println(e);
打印异常信息,e为所产生的异常。
输入样例:
new
zhang 10
new
wang 101
new
wang30
new
3a 100
new
wang 50
other
结尾无空行
输出样例:
Student [name=zhang, score=10]
IllegalScoreException: score out of range, score=101
java.util.NoSuchElementException
IllegalNameException: the first char of name must not be digit, name=3a
Student [name=wang, score=50]
scanner closed
import java.util.Arrays;
import java.util.Scanner;
class IllegalScoreException extends Exception{
public IllegalScoreException(){
}
public IllegalScoreException(String s) {
super(s);
}
}
class IllegalNameException extends Exception{
public IllegalNameException(){
}
public IllegalNameException(String s) {
super(s);
}
}
class Student{
private String name;
private int score;
public String getName() {
return name;
}
public void setName(String name) throws IllegalNameException {
if(name.charAt(0)>='0'&&name.charAt(0)<='9') {
throw new IllegalNameException("the first char of name must not be digit, name="+name);
}
this.name = name;
}
public int getScore() {
return score;
}
public void setScore(int score) {
this.score = score;
}
@Override
public String toString() {
return "Student [name=" + name + ", score=" + score + "]";
}
public int addScore(int score) throws IllegalScoreException {
if(this.score+score<0||this.score+score>100) {
throw new IllegalScoreException("score out of range, score="+score);
}
this.score+=score;
return this.score;
}
}
public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
String order = in.next();
while(!order.equals("other")) {
String name = in.next();
int score=0;
try {
Student aStudent = new Student();
score = in.nextInt();
aStudent.setName(name);
aStudent.addScore(score);
System.out.println(aStudent);
} catch (Exception e) {
// TODO Auto-generated catch block
if(e instanceof IllegalScoreException||e instanceof IllegalNameException) {
System.out.println(e);
}
else {
System.out.println("java.util.NoSuchElementException");
}
}
order = in.next();
}
in.close();
System.out.println("scanner closed");
}
}
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。
文章由极客之音整理,本文链接:https://www.bmabk.com/index.php/post/103103.html