Java | PTA:jmu-Java-06异常-01-常见异常

导读:本篇文章讲解 Java | PTA:jmu-Java-06异常-01-常见异常,希望对大家有帮助,欢迎收藏,转发!站点地址:www.bmabk.com

自己编码以产生常见异常。

###main方法:

  1. 事先定义好一个大小为5的数组。

  2. 根据屏幕输入产生相应异常

提示:可以使用System.out.println(e)打印异常对象的信息,其中e为捕获到的异常对象。

**输入说明: **

  1. arr 代表产生访问数组是产生的异常。然后输入下标,如果抛出ArrayIndexOutOfBoundsException异常则显示,如果不抛出异常则不显示。
  2. null,产生NullPointerException
  3. cast,尝试将String对象强制转化为Integer对象,产生ClassCastException
  4. num,然后输入字符,转化为Integer,如果抛出NumberFormatException异常则显示。
  5. 其他,结束程序。

输入样例:

arr 4
null
cast
num 8
arr 7
num a
other

结尾无空行

输出样例:

java.lang.NullPointerException
java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer
java.lang.ArrayIndexOutOfBoundsException: 7
java.lang.NumberFormatException: For input string: "a"
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		int []nums = new int[5];
		Scanner in = new Scanner(System.in);
		String str = in.next();
		while(str.equals("other")==false) {
			try {
				if(str.equals("null")) {
					throw new NullPointerException();
				}
				else if(str.equals("arr")) {
					int index = in.nextInt();
					if(index>4||index<0) {
						throw new ArrayIndexOutOfBoundsException(""+index);
					}
				}
				else if(str.equals("cast")) {
					throw new ClassCastException("java.lang.String cannot be cast to java.lang.Integer");
				}
				else if(str.equals("num")) {
					String num = in.next();
					if(!(num.charAt(0)>='0'&&num.charAt(0)<='9')) {
						throw new NumberFormatException("For input string: \""+num+"\"");
					}
				}
			}catch (Exception e) {
				// TODO: handle exception
				System.out.println(e);
			}
			str = in.next();
		}
	}
}

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

文章由极客之音整理,本文链接:https://www.bmabk.com/index.php/post/103105.html

(0)
小半的头像小半

相关推荐

极客之音——专业性很强的中文编程技术网站,欢迎收藏到浏览器,订阅我们!