Sum Problem

导读:本篇文章讲解 Sum Problem,希望对大家有帮助,欢迎收藏,转发!站点地址:www.bmabk.com

http://acm.hdu.edu.cn/showproblem.php?pid=1001

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 606504    Accepted Submission(s): 153369

 

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

 

 

Input

The input will consist of a series of integers n, one integer per line.

 

 

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

 

 

Sample Input

 

1 100

 

 

Sample Output

 

1 5050

 

 

Author

DOOM III


#include<stdio.h>

int main()
{
	int n,sum;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;
		while(n)
		{
			sum+=n;
			n--;
		}
		printf("%d\n\n",sum);
	}
	return 0;
}

 

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

文章由极客之音整理,本文链接:https://www.bmabk.com/index.php/post/69379.html

(0)
小半的头像小半

相关推荐

极客之音——专业性很强的中文编程技术网站,欢迎收藏到浏览器,订阅我们!